
<!DOCTYPE html>

<!--[if IE 8]> <html class="ie ie8" lang="en-US"
 xmlns:og="http://ogp.me/ns#"
 xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if IE 9]> <html class="ie ie9" lang="en-US"
 xmlns:og="http://ogp.me/ns#"
 xmlns:fb="http://ogp.me/ns/fb#"> <![endif]-->
<!--[if gt IE 9]><!--> <html lang="en-US"
 xmlns:og="http://ogp.me/ns#"
 xmlns:fb="http://ogp.me/ns/fb#"> <!--<![endif]-->

<head>


<meta charset="UTF-8" />
<title>  Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls</title>

 
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta http-equiv="X-UA-Compatible" content="IE=edge" />
<link rel="pingback" href="http://minnesotaconnected.com/xmlrpc.php" />
	

	
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Minnesota Connected &raquo; Feed" href="http://minnesotaconnected.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Minnesota Connected &raquo; Comments Feed" href="http://minnesotaconnected.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/minnesotaconnected.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='nggv-stars-css-css'  href='http://minnesotaconnected.com/wp-content/plugins/nextgen-gallery-voting/css/star_rating.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='http://minnesotaconnected.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='http://minnesotaconnected.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.3.1' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='wprssmi_template_styles-css'  href='http://minnesotaconnected.com/wp-content/plugins/wp-rss-multi-importer/templates/templates.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-pagenavi-css'  href='http://minnesotaconnected.com/wp-content/plugins/wp-pagenavi/pagenavi-css.css?ver=2.70' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-fonts-css'  href='http://fonts.googleapis.com/css?family=Open+Sans%3A400%2C400Italic%2C600%2C700%7CRoboto+Slab%7CMerriweather%3A300italic&#038;subset' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-core-css'  href='http://minnesotaconnected.com/wp-content/themes/smart-mag/style.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-responsive-css'  href='http://minnesotaconnected.com/wp-content/themes/smart-mag/css/responsive.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='pretty-photo-css'  href='http://minnesotaconnected.com/wp-content/themes/smart-mag/css/prettyPhoto.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='smartmag-font-awesome-css'  href='http://minnesotaconnected.com/wp-content/themes/smart-mag/css/fontawesome/css/font-awesome.min.css?ver=3.1.0' type='text/css' media='all' />
<script type='text/javascript' src='http://minnesotaconnected.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/plugins/nextgen-gallery-voting/js/ajaxify-stars.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/plugins/nextgen-gallery-voting/js/ajaxify-likes.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.3.1'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.3.1'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/themes/smart-mag/js/jquery.prettyPhoto.js?ver=4.8.2'></script>
<link rel='https://api.w.org/' href='http://minnesotaconnected.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://minnesotaconnected.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://minnesotaconnected.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;' href='http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/' />
<meta name="generator" content="WordPress 4.8.2" />
<link rel="canonical" href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/" />
<link rel='shortlink' href='http://minnesotaconnected.com/?p=1316505' />
<link rel="alternate" type="application/json+oembed" href="http://minnesotaconnected.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://minnesotaconnected.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F&#038;format=xml" />
<meta property="fb:app_id" content="282956821855947"/><!-- <meta name="vfb" version="2.9.4" /> -->
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//minnesotaconnected.com/?wordfence_lh=1&hid=6A7D549C9A82B12EE5B2F5CA069776E2');
</script><!-- <meta name="NextGEN" version="2.2.14" /> -->
<meta name="generator" content="Powered by Slider Revolution 5.4.3.1 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
		<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
.top-bar-content .textwidget p {
display: none;
}

section.author-info img {
float: left;
height: auto;
width: 100px;
}
		</style>
		
<!--[if lt IE 9]>
<script src="http://minnesotaconnected.com/wp-content/themes/smart-mag/js/html5.js" type="text/javascript"></script>
<![endif]-->


<script>
document.querySelector('head').innerHTML += '<style class="bunyad-img-effects-css">.main img, .main-footer img { opacity: 0; }</style>';
</script>
	

</head>


<body class="post-template-default single single-post postid-1316505 single-format-standard page-builder right-sidebar full img-effects has-nav-dark has-head-default">

<div class="main-wrap">

	
	
	<div class="top-bar">

		<div class="wrap">
			<section class="top-bar-content cf">
			
							
								<div class="trending-ticker">
					<span class="heading">Trending</span>

					<ul>
												
												
							<li><a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/" title="Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls">Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/" title="Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;">Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground">After ‘Stay At Home MN’- the Next COVID-19 Battleground</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/timberwolves-president-rosas-stalks-number-one-pick-and-salary-cap-vengeance_1316482/" title="Timberwolves President Rosas Stalks Number One Pick and Salary Cap Vengeance">Timberwolves President Rosas Stalks Number One Pick and Salary Cap Vengeance</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/when-legends-collide-a-tale-in-gustavus-adolphus-tennis-history_1316473/" title="When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History">When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/movie-review-sonic-the-hedgehog-is-generic-but-still-fun_1316467/" title="Movie Review &#8212; &#8216;Sonic the Hedgehog&#8217; is Generic, But Still Fun">Movie Review &#8212; &#8216;Sonic the Hedgehog&#8217; is Generic, But Still Fun</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/movie-review-january-produces-another-action-dud-with-the-rhythm-section_1316460/" title="Movie Review &#8212; January Produces Another Action Dud with &#8216;The Rhythm Section&#8217;">Movie Review &#8212; January Produces Another Action Dud with &#8216;The Rhythm Section&#8217;</a></li>
						
												
							<li><a href="http://minnesotaconnected.com/arts-entertainment/movie-review-the-gentlemen-is-guy-ritchie-doing-what-he-does-best_1316451/" title="Movie Review &#8212; &#8216;The Gentlemen&#8217; is Director Guy Ritchie Doing What He Does Best">Movie Review &#8212; &#8216;The Gentlemen&#8217; is Director Guy Ritchie Doing What He Does Best</a></li>
						
												
											</ul>
				</div>
				
									
					
		<div class="search">
			<form role="search" action="http://minnesotaconnected.com/" method="get">
				<input type="text" name="s" class="query live-search-query" value="" placeholder="Search..."/>
				<button class="search-button" type="submit"><i class="fa fa-search"></i></button>
			</form>
		</div> <!-- .search -->					
				
							<div class="textwidget"><p><ul class="social-icons cf"><li><a href="http://facebook.com/minnesotaconnected" class="icon fa fa-facebook" title="Facebook"><span class="visuallyhidden">Facebook</span></a></li><li><a href="http://twitter.com/mnconnected" class="icon fa fa-twitter" title="Twitter"><span class="visuallyhidden">Twitter</span></a></li></ul></p>
</div>
						
			</section>
		</div>
		
	</div>
	
	<div id="main-head" class="main-head">
		
		<div class="wrap">
			
			
			<header class="default">
			
				<div class="title">
							<a href="http://minnesotaconnected.com/" title="Minnesota Connected" rel="home">
		
														
								
				<img src="http://minnesotaconnected.com/wp-content/uploads/2017/10/logo.jpg" class="logo-image" alt="Minnesota Connected" />
					 
						
		</a>				</div>
				
									
					<div class="right">
										</div>
					
								
			</header>
				
							
				
<div class="main-nav">
	<div class="navigation-wrap cf">
	
		<nav class="navigation cf nav-dark">
		
			<div class>
			
				<div class="mobile" data-type="off-canvas" data-search="1">
					<a href="#" class="selected">
						<span class="text">Navigate</span><span class="current"></span> <i class="hamburger fa fa-bars"></i>
					</a>
				</div>
				
				<div class="menu-primary-container"><ul id="menu-primary" class="menu"><li id="menu-item-332" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-332"><a href="http://www.minnesotaconnected.com">Home</a></li>
<li id="menu-item-1315398" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-cat-44 menu-item-1315398"><a href="http://minnesotaconnected.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-1315399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-18616 menu-item-1315399"><a href="http://minnesotaconnected.com/category/news/editorial/">Editorial</a></li>
	<li id="menu-item-1315400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-113 menu-item-1315400"><a href="http://minnesotaconnected.com/category/news/local-happenings/">Local Happenings</a></li>
	<li id="menu-item-1315401" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-49 menu-item-1315401"><a href="http://minnesotaconnected.com/category/news/politics/">Politics</a></li>
</ul>
</li>
<li id="menu-item-1315402" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-4 menu-item-1315402"><a href="http://minnesotaconnected.com/category/arts-entertainment/">Arts/Entertainment</a>
<ul  class="sub-menu">
	<li id="menu-item-1315403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-110 menu-item-1315403"><a href="http://minnesotaconnected.com/category/arts-entertainment/art/">Art</a></li>
	<li id="menu-item-1315404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-5 menu-item-1315404"><a href="http://minnesotaconnected.com/category/arts-entertainment/movies/">Movies</a></li>
	<li id="menu-item-1315405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-6 menu-item-1315405"><a href="http://minnesotaconnected.com/category/arts-entertainment/music/">Music</a></li>
	<li id="menu-item-1315406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-7 menu-item-1315406"><a href="http://minnesotaconnected.com/category/arts-entertainment/sports/">Sports</a></li>
	<li id="menu-item-1315407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-111 menu-item-1315407"><a href="http://minnesotaconnected.com/category/arts-entertainment/theatre/">Theatre</a></li>
</ul>
</li>
<li id="menu-item-1315408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-cat-106 menu-item-1315408"><a href="http://minnesotaconnected.com/category/lifestyle/">Lifestyle</a>
<ul  class="sub-menu">
	<li id="menu-item-1315409" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-98 menu-item-1315409"><a href="http://minnesotaconnected.com/category/lifestyle/fashion/">Fashion</a></li>
	<li id="menu-item-1315410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-107 menu-item-1315410"><a href="http://minnesotaconnected.com/category/lifestyle/food/">Food</a></li>
	<li id="menu-item-1315411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-112 menu-item-1315411"><a href="http://minnesotaconnected.com/category/lifestyle/local-businesses/">Local Businesses</a></li>
	<li id="menu-item-1315412" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-108 menu-item-1315412"><a href="http://minnesotaconnected.com/category/lifestyle/outdoors/">Outdoors</a></li>
	<li id="menu-item-1315413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-109 menu-item-1315413"><a href="http://minnesotaconnected.com/category/lifestyle/travel/">Travel</a></li>
</ul>
</li>
<li id="menu-item-1315414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-cat-8 menu-item-1315414"><a href="http://minnesotaconnected.com/category/events/">Events</a></li>
<li id="menu-item-1315388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-1315388"><a href="http://minnesotaconnected.com/about-us/">About Us</a>
<ul  class="sub-menu">
	<li id="menu-item-1315389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1315389"><a href="http://minnesotaconnected.com/contributors/">Contributors</a></li>
	<li id="menu-item-1315390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1315390"><a href="http://minnesotaconnected.com/contribute/">Contribute</a></li>
	<li id="menu-item-1315391" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1315391"><a href="http://minnesotaconnected.com/submit-news/">Submit News</a></li>
	<li id="menu-item-1315392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1315392"><a href="http://minnesotaconnected.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li id="menu-item-1315379" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1315379"><a target="_blank" href="http://realestate.minnesotaconnected.com">Real Estate</a></li>
</ul></div>				
						
			</div>
			
		</nav>
	
				
	</div>
</div>				
							
		</div>
		
				
	</div>	
	<div class="breadcrumbs-wrap">
		
		<div class="wrap">
		<div class="breadcrumbs"><span class="location">You are at:</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="http://minnesotaconnected.com/"><span itemprop="title">Home</span></a></span><span class="delim">&raquo;</span><span itemscope itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url"  href="http://minnesotaconnected.com/category/news/"><span itemprop="title">News</span></a></span><span class="delim">&raquo;</span><span class="current">Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls</span></div>		</div>
		
	</div>


<div class="main wrap cf">

		
	<div class="row">
	
		<div class="col-8 main-content">
		
				
				
<article id="post-1316505" class="post-1316505 post type-post status-publish format-standard has-post-thumbnail category-news tag-covid-19 tag-minnesota-covid-19">
	
	<header class="post-header cf">
	
	
		
		
				<div class="heading cf">
				
			<h1 class="post-title item fn">
			Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls			</h1>
			
			<a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/#respond" class="comments"><i class="fa fa-comments-o"></i> 0</a>
		
		</div>

		<div class="post-meta cf">
			<span class="posted-by">By 
				<span class="reviewer"><a href="http://minnesotaconnected.com/author/trandsgaard/" title="Posts by Tony Randgaard" rel="author">Tony Randgaard</a></span>
			</span>
			 
			<span class="posted-on">on				<span class="dtreviewed">
					<time class="value-title" datetime="2020-05-04T16:54:44-05:00" title="2020-05-04">May 4, 2020</time>
				</span>
			</span>
			
			<span class="cats"><a href="http://minnesotaconnected.com/category/news/" rel="category tag">News</a></span>
				
		</div>		
			
	</header><!-- .post-header -->

	

	<div class="post-container cf">
	
		<div class="post-content-right">
			<div class="post-content description ">
	
					
				
		<p><a href="http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid.jpg"><img class="size-full wp-image-1316509 aligncenter" src="http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid.jpg" alt="" width="799" height="533" srcset="http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid.jpg 799w, http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid-300x200.jpg 300w, http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid-768x512.jpg 768w" sizes="(max-width: 799px) 100vw, 799px" /></a></p>
<p class="x_MsoNormal">Gill Brothers Funeral and Cremation served Minnesota families by horse and buggy when it was founded in 1889 and has been family-owned ever since. When its President Dan McGraw, a funeral director since 1981, tells me the last two months have been “unprecedented,” he draws my undivided attention. McGraw explained that during the regular course of business, he picks up approximately two thirds of his decedents at long term care facilities or at private residences.</p>
<p class="x_MsoNormal">As a result, COVID testing has often not been feasible. During February and March, he said that many of those cause-of-deaths were recorded as COPD, Sepsis or pneumonia. Today, McGraw and other funeral directors we contacted, report striking increases in “COVID-19” as the cause of death. That may sound like a blinding flash of the obvious, but we invite you to follow us as we peel back the curtain on Minnesota’s runaway COVID-19 death count. &nbsp;&nbsp;&nbsp;&nbsp;</p>
<p class="x_MsoNormal"><span id="more-1316505"></span>The CDC issued new COVID-19 cause-of-death guidance on April 2<sup>nd</sup>. The CDC directed that if COVID was the most immediate and direct effect, it must be listed as the cause of death. McGraw and others believe this policy is dramatically inflating the impact of COVID here and across the nation.</p>
<p class="x_MsoNormal">One need only look at New York City for the startling impact of reclassifying untested long term care deaths. The New York Times reported that on April 14<sup>th</sup>, New York City changed 3700 untested deaths to probable COVID-19 deaths — increasing their COVID-19 death toll by more than 50 percent in one fell swoop.</p>
<p class="x_MsoNormal">We spoke with another Twin Cities funeral director responsible for transporting hundreds of state decedents. During the interview, he consulted a list of approved COVID symptoms that he keeps close at hand. “Fever, shortness of breath, dry cough, chills, headache, muscle aches and sore throat.” And then asked incredulously: “Medical examiners and certifiers are using those symptoms that could easily be a cold or flu and making a determination that the cause of death is COVID-19.”</p>
<p class="x_MsoNormal">The majority of his company’s April recoveries have been categorized as COVID-19. The recovery of those remains adds extra costs in time and (PPE) protective equipment required. Further, he recounted a recent pick-up; dispatched for a deceased male with terminal cancer, in hospice at home. He was very surprised to find that COVID-19 was recorded as the cause of death. At Gill Brothers, Dan McGraw reported a similar incident where he recovered a 50 year old male in hospice for a different disease and again COVID-19 was the cause of death.</p>
<p class="x_MsoNormal">The Twin Cities director was agitated when he asked: &nbsp;“What useful purpose is being served to clump together decedents that passed away&nbsp;<b>with COVID-19</b>, and not necessarily as a direct cause? In his view, much of the rising Minnesota death toll was being fueled by loved ones passing “<u>with COVID-19</u>,&nbsp;<u>not from COVID-19</u>.”</p>
<div id="attachment_1316507" style="width: 957px" class="wp-caption alignnone"><a href="http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director.jpg"><img class="wp-image-1316507 size-full" src="http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director.jpg" alt="" width="947" height="679" srcset="http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director.jpg 947w, http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director-300x215.jpg 300w, http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director-768x551.jpg 768w, http://minnesotaconnected.com/wp-content/uploads/2020/05/covid-funeral-director-269x192.jpg 269w" sizes="(max-width: 947px) 100vw, 947px" /></a><p class="wp-caption-text">Dan McGraw: Gill Brother Funeral</p></div>
<p class="x_MsoNormal">On the other side of the world, his question is being answered. Sweden is being showcased as a model for laissez-faire management. They have not employed any lockdowns.&nbsp; One of their key strategies is transparency. According to Stuff New Zealand, every time a Swedish patient is admitted, a live public web-site is updated in stunning detail.&nbsp;<i>Average age: 60. &nbsp;Those with underlying health conditions: 77 percent.&nbsp;</i>And then the stark contrast. Sweden determines if the patient died from COVID-19 or from another disease “with COVID19.” This approach can mean significant differences in how governments, health authorities and the media treat the pandemic.&#8217;</p>
<p class="x_MsoNormal">It goes without saying that health statistics juicing COVID-19 numbers can facilitate blown health models and flawed public policy decisions. The University of Washington’s IHME model, which is used by the White House and many government agencies for planning has raised its projected death toll from 60,000 to 74,073 in a matter of just three weeks.</p>
<p class="x_MsoNormal">Back in Minnesota, Governor Walz extended the stay at home order until May 18<sup>th</sup>. It is hard to argue with the extension with ramped-up testing yielding record positive patients and the “official COVID-19 death count” steadily increasing. Behind the numbers, the Minnesota Department of Health reported on Wednesday that 99.2% of Minnesota COVID-19 deaths have occurred in long term care facilities or among people with significant underlying health conditions. Of 343 deaths through last week, 271 or 79 percent occurred in long term care facilities. Most of those fatalities are now being tested to confirm COVID-19.</p>
<p>In the meantime, Minnesota funeral directors like Dan McGraw continue to provide caring funeral services in the trenches. Thomas Wolfe called death, “the last voyage, the longest, the best.” For Gill Brothers Funeral and Cremation, that voyage was once escorted by horse carriage but today is led by funeral directors armed with surgical masks, gowns and gloves.&nbsp;</p>
<p>&nbsp;</p>
		
		
		
				
				
			</div><!-- .post-content -->
		</div>
		
	</div>
	
	
	
	
	<div class="post-share">
		<span class="text">Share.</span>
		
		<span class="share-links">

			<a href="http://twitter.com/home?status=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" class="fa fa-twitter" title="Tweet It" target="_blank">
				<span class="visuallyhidden">Twitter</span></a>
				
			<a href="http://www.facebook.com/sharer.php?u=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" class="fa fa-facebook" title="Share on Facebook" target="_blank">
				<span class="visuallyhidden">Facebook</span></a>
				
			<a href="http://plus.google.com/share?url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" class="fa fa-google-plus" title="Share on Google+" target="_blank">
				<span class="visuallyhidden">Google+</span></a>
				
			<a href="http://pinterest.com/pin/create/button/?url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F&amp;media=http%3A%2F%2Fminnesotaconnected.com%2Fwp-content%2Fuploads%2F2020%2F05%2Fcemetery-covid.jpg" class="fa fa-pinterest"
				title="Share on Pinterest" target="_blank">
				<span class="visuallyhidden">Pinterest</span></a>
				
			<a href="http://www.linkedin.com/shareArticle?mini=true&amp;url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" class="fa fa-linkedin" title="Share on LinkedIn" target="_blank">
				<span class="visuallyhidden">LinkedIn</span></a>
				
			<a href="http://www.tumblr.com/share/link?url=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F&amp;name=Minnesota+Funeral+Directors+Grapple+With+Inflated+COVID-19+Death+Tolls" class="fa fa-tumblr"
				title="Share on Tumblr" target="_blank">
				<span class="visuallyhidden">Tumblr</span></a>
				
			<a href="mailto:?subject=Minnesota%20Funeral%20Directors%20Grapple%20With%20Inflated%20COVID-19%20Death%20Tolls&amp;body=http%3A%2F%2Fminnesotaconnected.com%2Fnews%2Fminnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505%2F" class="fa fa-envelope-o"
				title="Share via Email">
				<span class="visuallyhidden">Email</span></a>
			
		</span>
	</div>
	
		
</article>




	<div class="author-box">
		<h3 class="section-head">About Author</h3>

				<section class="author-info">
		
			<img src="http://minnesotaconnected.com/wp-content/uploads/userphoto/49.thumbnail.jpg" alt="Tony Randgaard" width="60" height="80" class="photo" />			
			<div class="description">
				<a href="http://minnesotaconnected.com/author/trandsgaard/" title="Posts by Tony Randgaard" rel="author">Tony Randgaard</a>				
				<ul class="social-icons">
								</ul>
				
				<p class="bio">Retired after more than 20 years in marketing with United and Northwest Airlines, Tony has been published by the Star and Tribune, Minnesota Monthly, MinnPost, Minnesota Connected, Air Cargo News, The Forward, CNS Air Cargo Focus and the TC Daily Planet. As a result, he has been a regular guest on the CBS-Entercom Radio ‘Jordana Green Show’ in the Midwest. His cold case mystery novel Unpremeditated: A Murderous Caribbean Travelogue — is available now on Amazon.</p>
			</div>
			
		</section>	</div>


	
	<section class="related-posts">
		<h3 class="section-head"><span class="color">Related</span> Posts</h3> 
		<ul class="highlights-box three-col related-posts">
		
				
			<li class="highlights column one-third">
				
				<article>
						
					<a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground" class="image-link">
						<img width="214" height="140" src="http://minnesotaconnected.com/wp-content/uploads/2020/04/So-Korea-Emergency-Team-Facebook-214x140.jpg" class="image wp-post-image" alt="" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground" />	
											</a>
					
								<div class="cf listing-meta meta above">
					
				<time datetime="2020-04-02T14:49:16-05:00" class="meta-item">April 2, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
					<h2><a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground">After ‘Stay At Home MN’- the Next COVID-19 Battleground</a></h2>
					
										
				</article>
			</li>
			
				
			<li class="highlights column one-third">
				
				<article>
						
					<a href="http://minnesotaconnected.com/arts-entertainment/when-legends-collide-a-tale-in-gustavus-adolphus-tennis-history_1316473/" title="When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History" class="image-link">
						<img width="214" height="140" src="http://minnesotaconnected.com/wp-content/uploads/2020/03/Wilk-Statue-35th-Anniv-Celebration-214x140.jpg" class="image wp-post-image" alt="" title="When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History" />	
											</a>
					
								<div class="cf listing-meta meta above">
					
				<time datetime="2020-03-01T16:09:46-05:00" class="meta-item">March 1, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/arts-entertainment/when-legends-collide-a-tale-in-gustavus-adolphus-tennis-history_1316473/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
					<h2><a href="http://minnesotaconnected.com/arts-entertainment/when-legends-collide-a-tale-in-gustavus-adolphus-tennis-history_1316473/" title="When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History">When Legends Collide &#8212; A Tale in Gustavus Adolphus Tennis History</a></h2>
					
										
				</article>
			</li>
			
				
			<li class="highlights column one-third">
				
				<article>
						
					<a href="http://minnesotaconnected.com/news/grand-theft-airline_1316439/" title="Grand Theft Airline" class="image-link">
						<img width="214" height="140" src="http://minnesotaconnected.com/wp-content/uploads/2020/01/Delta-cargo-load-delta-website-214x140.jpg" class="image wp-post-image" alt="" title="Grand Theft Airline" />	
											</a>
					
								<div class="cf listing-meta meta above">
					
				<time datetime="2020-01-17T19:21:44-05:00" class="meta-item">January 17, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/grand-theft-airline_1316439/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
					<h2><a href="http://minnesotaconnected.com/news/grand-theft-airline_1316439/" title="Grand Theft Airline">Grand Theft Airline</a></h2>
					
										
				</article>
			</li>
			
				</ul>
	</section>

	
				<div class="comments">
				
	
	<div id="comments">

			<p class="nocomments">Comments are closed.</p>
		
	
	
	</div><!-- #comments -->
				</div>
	
				
		</div>
		
		
			
		
		
		<aside class="col-4 sidebar">
		
					<div class="">
			
				<ul>
				
					
			<li id="bunyad-tabbed-recent-widget-2" class="widget tabbed">	
			<ul class="tabs-list">
			
								
				<li class="active">
					<a href="#" data-tab="1">Recent</a>
				</li>
				
								
				<li class="">
					<a href="#" data-tab="2">Videos</a>
				</li>
				
								
				<li class="">
					<a href="#" data-tab="3">Popular</a>
				</li>
				
								
			</ul>
			
			<div class="tabs-data">
									
				<ul class="tab-posts active posts-list" id="recent-tab-1">
				
								
						
					<li>
					
						<a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2020-05-04T16:54:44-05:00" class="meta-item">May 4, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/" title="Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls">
								Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls</a>
								
																									
						</div>
					
					</li>
					
						
					<li>
					
						<a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/04/drive-to-survive-season-2-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2020-04-06T20:29:36-05:00" class="meta-item">April 6, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/" title="Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;">
								Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;</a>
								
																									
						</div>
					
					</li>
					
						
					<li>
					
						<a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/04/So-Korea-Emergency-Team-Facebook-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2020-04-02T14:49:16-05:00" class="meta-item">April 2, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground">
								After ‘Stay At Home MN’- the Next COVID-19 Battleground</a>
								
																									
						</div>
					
					</li>
					
										
									
				</ul>
									
				<ul class="tab-posts  posts-list" id="recent-tab-2">
				
								
						
					<li>
					
						<a href="http://minnesotaconnected.com/lifestyle/mccain-v-franken-in-vikings-pregame-skit_881584/"><img width="96" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2015/12/Screen-Shot-2015-12-11-at-11.23.12-AM-150x150.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="McCain v. Franken in Vikings&#8217; Pregame Skit" srcset="http://minnesotaconnected.com/wp-content/uploads/2015/12/Screen-Shot-2015-12-11-at-11.23.12-AM-150x150.png 150w, http://minnesotaconnected.com/wp-content/uploads/2015/12/Screen-Shot-2015-12-11-at-11.23.12-AM-110x110.png 110w, http://minnesotaconnected.com/wp-content/uploads/2015/12/Screen-Shot-2015-12-11-at-11.23.12-AM-50x50.png 50w" sizes="(max-width: 96px) 100vw, 96px" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2015-12-11T11:30:40-05:00" class="meta-item">December 11, 2015</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/lifestyle/mccain-v-franken-in-vikings-pregame-skit_881584/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/lifestyle/mccain-v-franken-in-vikings-pregame-skit_881584/" title="McCain v. Franken in Vikings&#8217; Pregame Skit">
								McCain v. Franken in Vikings&#8217; Pregame Skit</a>
								
																									
						</div>
					
					</li>
					
						
					<li>
					
						<a href="http://minnesotaconnected.com/lifestyle/breaking-bad-tribute-video-will-make-you-want-to-watch-it-all-again_240122/"><img width="96" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2014/05/BreakingBad-tribute-video-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="&#8216;Breaking Bad&#8217; Tribute Video Will Make You Want to Watch it All Again" srcset="http://minnesotaconnected.com/wp-content/uploads/2014/05/BreakingBad-tribute-video-150x150.jpg 150w, http://minnesotaconnected.com/wp-content/uploads/2014/05/BreakingBad-tribute-video-110x110.jpg 110w, http://minnesotaconnected.com/wp-content/uploads/2014/05/BreakingBad-tribute-video-50x50.jpg 50w" sizes="(max-width: 96px) 100vw, 96px" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2014-05-07T13:05:47-05:00" class="meta-item">May 7, 2014</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/lifestyle/breaking-bad-tribute-video-will-make-you-want-to-watch-it-all-again_240122/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/lifestyle/breaking-bad-tribute-video-will-make-you-want-to-watch-it-all-again_240122/" title="&#8216;Breaking Bad&#8217; Tribute Video Will Make You Want to Watch it All Again">
								&#8216;Breaking Bad&#8217; Tribute Video Will Make You Want to Watch it All Again</a>
								
																									
						</div>
					
					</li>
					
										
									
				</ul>
									
				<ul class="tab-posts  posts-list" id="recent-tab-3">
				
								
						
					<li>
					
						<a href="http://minnesotaconnected.com/arts-entertainment/sports/minnesota-wild-net-huge-win-versus-the-streaking-los-angeles-kings_98/"><img width="96" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-24-at-12.54.12-AM-150x150.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Minnesota Wild Net Huge Win Versus the Streaking Los Angeles Kings" srcset="http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-24-at-12.54.12-AM-150x150.png 150w, http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-24-at-12.54.12-AM-110x110.png 110w, http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-24-at-12.54.12-AM-50x50.png 50w" sizes="(max-width: 96px) 100vw, 96px" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2013-04-23T05:59:19-05:00" class="meta-item">April 23, 2013</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/arts-entertainment/sports/minnesota-wild-net-huge-win-versus-the-streaking-los-angeles-kings_98/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/arts-entertainment/sports/minnesota-wild-net-huge-win-versus-the-streaking-los-angeles-kings_98/" title="Minnesota Wild Net Huge Win Versus the Streaking Los Angeles Kings">
								Minnesota Wild Net Huge Win Versus the Streaking Los Angeles Kings</a>
								
																									
						</div>
					
					</li>
					
						
					<li>
					
						<a href="http://minnesotaconnected.com/events/minneapolisfilmfestival_72/"><img width="96" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2013/04/stanightweb1-150x150.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Check Out the Minneapolis &#8211; St. Paul International Film Festival" srcset="http://minnesotaconnected.com/wp-content/uploads/2013/04/stanightweb1-150x150.jpg 150w, http://minnesotaconnected.com/wp-content/uploads/2013/04/stanightweb1-110x110.jpg 110w, http://minnesotaconnected.com/wp-content/uploads/2013/04/stanightweb1-50x50.jpg 50w" sizes="(max-width: 96px) 100vw, 96px" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2013-04-24T03:54:05-05:00" class="meta-item">April 24, 2013</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/events/minneapolisfilmfestival_72/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/events/minneapolisfilmfestival_72/" title="Check Out the Minneapolis &#8211; St. Paul International Film Festival">
								Check Out the Minneapolis &#8211; St. Paul International Film Festival</a>
								
																									
						</div>
					
					</li>
					
						
					<li>
					
						<a href="http://minnesotaconnected.com/arts-entertainment/movies/first-trailer-for-the-coen-brothers-new-film-inside-llewyn-davis_86/"><img width="96" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-23-at-11.45.01-PM-150x150.png" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="First Trailer for The Coen Brothers New Film &#8216;Inside Llewyn Davis&#8217;" srcset="http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-23-at-11.45.01-PM-150x150.png 150w, http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-23-at-11.45.01-PM-110x110.png 110w, http://minnesotaconnected.com/wp-content/uploads/2013/04/Screen-Shot-2013-04-23-at-11.45.01-PM-50x50.png 50w" sizes="(max-width: 96px) 100vw, 96px" />	
																									
						</a>
						
						<div class="content">
						
										<div class="cf listing-meta meta above">
					
				<time datetime="2013-04-24T04:47:31-05:00" class="meta-item">April 24, 2013</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/arts-entertainment/movies/first-trailer-for-the-coen-brothers-new-film-inside-llewyn-davis_86/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
								
							<a href="http://minnesotaconnected.com/arts-entertainment/movies/first-trailer-for-the-coen-brothers-new-film-inside-llewyn-davis_86/" title="First Trailer for The Coen Brothers New Film &#8216;Inside Llewyn Davis&#8217;">
								First Trailer for The Coen Brothers New Film &#8216;Inside Llewyn Davis&#8217;</a>
								
																									
						</div>
					
					</li>
					
										
									
				</ul>
							
			</div>
			
			</li>
		
				
				</ul>
		
			</div>
		
		</aside>
		
		
	</div> <!-- .row -->
		
	
</div> <!-- .main -->


		
	<footer class="main-footer">
	
			<div class="wrap">
		
					<ul class="widgets row cf">
				
		<li class="widget col-4 bunyad-about">			<h3 class="widgettitle">About</h3>		
			<div class="about-widget">
			
							<p class="logo-text">Minnesota Connected</p>
				
						
			<p>Minnesota Connected operates hyper-local news websites all around the state of Minnesota. We are dedicated to timely reporting on local government, school news, sports, music and other happenings in your neighborhood.</p>
			
			</div>
		
		</li>		
		
			<li class="widget col-4 latest-posts">			
							<h3 class="widgettitle">Recent Posts</h3>						
			<ul class="posts-list">
			
							<li>
				
					<a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/05/cemetery-covid-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls" />					
																					
					</a>
					
					<div class="content">
					
									<div class="cf listing-meta meta above">
					
				<time datetime="2020-05-04T16:54:44-05:00" class="meta-item">May 4, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
						<a href="http://minnesotaconnected.com/news/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505/" title="Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls">
							Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/04/drive-to-survive-season-2-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;" />					
																					
					</a>
					
					<div class="content">
					
									<div class="cf listing-meta meta above">
					
				<time datetime="2020-04-06T20:29:36-05:00" class="meta-item">April 6, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
						<a href="http://minnesotaconnected.com/arts-entertainment/quarantine-netflix-binge-recommendation-formula-1-drive-to-survive_1316487/" title="Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;">
							Quarantine Netflix Binge Recommendation &#8211; &#8216;Formula 1: Drive to Survive&#8217;</a>
							
																							
					</div>
				
				</li>
							<li>
				
					<a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/"><img width="110" height="96" src="http://minnesotaconnected.com/wp-content/uploads/2020/04/So-Korea-Emergency-Team-Facebook-110x96.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground" />					
																					
					</a>
					
					<div class="content">
					
									<div class="cf listing-meta meta above">
					
				<time datetime="2020-04-02T14:49:16-05:00" class="meta-item">April 2, 2020</time><span class="meta-item comments"><a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/#respond"><i class="fa fa-comments-o"></i> 0</a></span>					
			</div>
							
						<a href="http://minnesotaconnected.com/news/after-stay-at-home-mn-the-next-covid-19-battleground_1316489/" title="After ‘Stay At Home MN’- the Next COVID-19 Battleground">
							After ‘Stay At Home MN’- the Next COVID-19 Battleground</a>
							
																							
					</div>
				
				</li>
						</ul>
			
			</li><li class="widget col-4 widget-social"><h3 class="widgettitle">Connect With Us</h3>		
		<ul class="social-follow" itemscope itemtype="http://schema.org/Organization">
			<link itemprop="url" href="http://minnesotaconnected.com/">
						
				<li class="service">

					<a href="https://facebook.com/minnesotaconnected" class="service-link facebook cf" target="_blank" itemprop="sameAs">
						<i class="icon fa fa-facebook-square"></i>
						<span class="label">Like on Facebook</span>
						
											</a>

				</li>
			
						
				<li class="service">

					<a href="https://twitter.com/mnconnected" class="service-link twitter cf" target="_blank" itemprop="sameAs">
						<i class="icon fa fa-twitter"></i>
						<span class="label">Follow on Twitter</span>
						
											</a>

				</li>
			
					</ul>
		
		</li>			</ul>
				
		</div>
	
		
	
			<div class="lower-foot">
			<div class="wrap">
		
						
			<div class="widgets">
							<div class="textwidget"><p>© COPYRIGHT 2017 <a href="http://www.minnesotaconnected.com/" target="_blank" rel="noopener">MINNESOTA CONNECTED</a></p>
</div>
					</div>
			
					
			</div>
		</div>		
		
	</footer>
	
</div> <!-- .main-wrap -->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://minnesotaconnected.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"http:\/\/minnesotaconnected.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var Bunyad = {"ajaxurl":"http:\/\/minnesotaconnected.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/themes/smart-mag/js/bunyad-theme.js?ver=3.1.0'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/themes/smart-mag/js/jquery.flexslider-min.js?ver=3.1.0'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-content/themes/smart-mag/js/jquery.sticky-sidebar.min.js?ver=3.1.0'></script>
<script type='text/javascript' src='http://minnesotaconnected.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-54845652-1"></script>
<script>
 window.dataLayer = window.dataLayer || [];
 function gtag(){dataLayer.push(arguments);}
 gtag('js', new Date());

 gtag('config', 'UA-54845652-1');
</script>

<script src="//static.getclicky.com/js" type="text/javascript"></script>
<script type="text/javascript">try{ clicky.init(100603178); }catch(e){}</script>
<noscript>

<img alt="Clicky" width="1" height="1" src="//in.getclicky.com/100603178ns.gif" />

</noscript><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"Article","headline":"Minnesota Funeral Directors Grapple With Inflated COVID-19 Death Tolls","url":"http:\/\/minnesotaconnected.com\/news\/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505\/","image":{"@type":"ImageObject","url":"http:\/\/minnesotaconnected.com\/wp-content\/uploads\/2020\/05\/cemetery-covid-702x336.jpg","width":702,"height":336},"datePublished":"2020-05-04T16:54:44-05:00","dateModified":"2020-05-04T16:59:09-05:00","author":{"@type":"Person","name":"Tony Randgaard"},"publisher":{"@type":"Organization","name":"Minnesota Connected","logo":{"@type":"ImageObject","url":"http:\/\/minnesotaconnected.com\/wp-content\/uploads\/2017\/10\/logo.jpg"}},"mainEntityOfPage":{"@type":"WebPage","@id":"http:\/\/minnesotaconnected.com\/news\/minnesota-funeral-directors-grapple-with-inflated-covid-19-death-tolls_1316505\/"}}</script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=282956821855947&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

</body>
</html>